составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различны. удалить из него минимальный элемент.

Ytkin4560 Ytkin4560    3   09.06.2019 11:40    1

Ответы
2003lyuba 2003lyuba  08.07.2020 08:42
Const
    m = 10; 
var
    a: array[1..m] of integer;
    i,j, min: integer;
begin     
write ('Исходный массив: ');   
for i := 1 to m do
  begin
  a[i] := random(100);
  if (i=1) or (a[i]<min) then min:=a[i];
  write (a[i],'; ');
  end;   
writeln; 
for i:=1 to m do
  begin
  if a[i]=min then
    begin
    for j:=i to m-1 do
      a[j]:=a[j+1];
    break;
    end;
  end;
a[m]:=0;
write('Измененный массив: ');  
for i := 1 to m-1 do
         write (a[i],'; ');  
end.
составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различ
составить блок схему. составить программу на языке паскаль. дан массив в котором все элементы различ
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика