Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функции f(x) для х є [a;b]
(a,b - целые, a>b) с шагом -1​

Элилия Элилия    3   16.05.2020 00:08    3

Ответы
ИванПро228 ИванПро228  14.10.2020 20:25

f(x) = x2 -2

сам решал могут быть не большие погрешности

ПОКАЗАТЬ ОТВЕТЫ
115544 115544  14.10.2020 20:25

program z1;

var a,b,x: integer;

f:real;

begin

write ('a = ');

readln (a);

write ('b = ');

readln (b);

for x:=a to b do

begin  

if x>2 then f:=x*x-3

else if x<-2 then f:=x/3

else f:=abs(x-2);

writeln ('f(',x:2,') = ',f)

end

end.

Объяснение:

Смотри картинку

Это цикл для a < b c шагом 1.

Если цикл для a > b c шагом -1, то 9 строку (for x:=a to b do) заменяем на for x:=a downto b do.


Составить блок-схему и написать программу на языке Паскаль выводящую на экран таблицу значений функц
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика