Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа либо произведение нечетного четырехзначного числа

катяkfrr катяkfrr    2   15.09.2019 23:10    1

Ответы
Boom111111111111 Boom111111111111  07.10.2020 18:30
Программа:
program abc;
var x,s,p:integer;
begin
writeln('Введите четырехзначное число');
readln(x);
if (x mod 2)=0 then
begin
  s:=(x mod 10)+(x div 10 mod 10)+(x div 100 mod 10)+x div 1000;
  writeln('s=',s);
  end
else
  begin
  p:=(x mod 10)*(x div 10 mod 10)*(x div 100 mod 10)*x div 1000;
  writeln('p=',p);
  end;
end.
Блок-схема

Составить блок схему и написать программу которая находит сумму цифр четного четырехзначного числа л
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика