Составить алгоритм, написать программу, которая заполняет массив из 20 данных случайными числами и делят его на два массива, в один помещает четные числа в другой нечетные. вывести исходный массив, массив четных чисел и нечетных чисел.

ArtemTony ArtemTony    3   22.05.2019 12:20    1

Ответы
Конецначала Конецначала  01.10.2020 07:21

var

  a,b,c:array [1..20] of integer;

  i,k,l:integer;

begin

  randomize;

  k:=1;

  l:=1; 

  writeln ('Исходный массив: '); 

  for i:=1 to 20 do

   begin

    a[i]:=random(9)+1;

    if a[i] mod 2 = 0 then

     begin

      b[k]:=a[i];

      inc(k);

     end else

      begin

       c[l]:=a[i];

       inc(l);

      end; 

    write (a[i],' ');

  end;

  k:=k-1;

  l:=l-1; 

  writeln;

  writeln ('Массив четных чисел');

  for i:=1 to k do write (b[i],' ');

  writeln;

  writeln ('Массив нечетных чисел');

  for i:=1 to l do write (c[i],' ');

  writeln;

  readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика