Составить алгоритм и написать программу вычисления значений функции f (х) на отрезке [a; b] c шагом h.результат представить в виде таблицы,первый столбец которой - значение аргумента,второй - соответствующие значения функции. f(x)=2cosx-1

Kanesan Kanesan    1   09.06.2019 00:30    4

Ответы
Kannb Kannb  07.07.2020 23:12
Var
  a, b, h, x: real;

begin
  writeln('Введите начальное значение, конечное значение и шаг ');
  readln(a, b, h);
  x := a;
  while x <= b do
  begin
    writeln(x:5:2,' ',2 * cos(x) - 1:10:7);
    x := x + h
  end
end.

Тест:
Введите начальное значение, конечное значение и шаг
-1.8 1.6 0.2
-1.80 -1.4544042
-1.60 -1.0583990
-1.40 -0.6600657
-1.20 -0.2752845
-1.00  0.0806046
-0.80  0.3934134
-0.60  0.6506712
-0.40  0.8421220
-0.20  0.9601332
 0.00  1.0000000
 0.20  0.9601332
 0.40  0.8421220
 0.60  0.6506712
 0.80  0.3934134
 1.00  0.0806046
 1.20 -0.2752845
 1.40 -0.6600657
 1.60 -1.0583990
ПОКАЗАТЬ ОТВЕТЫ
витя55346 витя55346  07.07.2020 23:12
Var
  a, b, h: real;

begin
  writeln('a b h');
  readln(a, b, h);
  writeln('');
  repeat
    writeln('|', a:3, 2 * cos(a) - 1:12:7, '|');
    a += h;
  until (a > b);
  writeln('');
end.

Табличка:)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика