Составить алгоритм и написать программу вычисления площади фигуры с использованием условного оператора if по одной из формул: s=п*r ; s=a*b

ekaterina5velikaya ekaterina5velikaya    2   22.05.2019 10:00    4

Ответы
nura20061 nura20061  17.06.2020 15:48

var

s,r,a,b:real;

k:byte; 

begin

repeat 

write ('1 - S kruga; 2 - S  pryamougolnika: ');readln(k);

until (k=1) or (k=2); 

if k=1 then begin

write ('Radius: ');readln(r);

s:=pi*r;

writeln ('S = ',s:0:5);

end else begin

write ('A = ');readln(a);

write('B = ');readln(b);

s:=a*b;

writeln ('S = ',s:0:4);

end;

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика