Составить алгоритм и написать программу для вычисления факториала числа. факториал числа обозначается n! , произносится эн факториа́л) — произведение всех натуральных чисел от 1 до n включительно: n ! = 1 ⋅ 2 ⋅ . 0! =1. пример: 4! = 1*2*3*4 = 24. выполнить двумя цикл с предусловием и с фиксированым числом повторений). все переменные целочисленные.

egorkarevyakin egorkarevyakin    2   26.08.2019 10:40    2

Ответы
qqwweerrqq qqwweerrqq  03.08.2020 08:53
Var n,f,i:integer;
begin
write('n = ');
readln(n);
f:=1;
for i:=2 to n do f:=f*i;
writeln(n,'! = ',f);
end.

Пример:
n = 6
6! = 720
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика