Сосновами java!

напишите программу где я ввожу логин и пароль. и если они , то мы выводим authentication completed, иначе invalid login or password.

(логин должен быть user, пароль - qwerty)

сравнение строк вы делаете с метода

kristinavasina1 kristinavasina1    1   11.07.2019 09:36    9

Ответы
Dimaplayfifa1611 Dimaplayfifa1611  17.09.2020 19:23

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:Импортируем класс Scanner(для ввода текста);В методе main создаем две переменные типа String и одну типа Scanner;Вводим значения при а;Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;Закрываем Scanner;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика