Сортировка по сумме цифр
Напишите программу, которая сортирует натуральные числа в массиве по убыванию суммы цифр десятичной записи числа. При равенстве сумм цифр числа должны сохранить исходный порядок.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел — элементы массива. Гарантируется, что 0
Выходные данные

Программа должна вывести в одной строке элементы массива, отсортированного в порядке убывания суммы цифр десятичной записи числа, разделив их пробелами.

Примеры
Ввод
Вывод
6
9 21 32 55 81 11
55 9 81 32 21 11
Решите на C++ или python

lisovak0777 lisovak0777    2   23.05.2020 09:17    107

Ответы
aigulzhan aigulzhan  15.10.2020 06:53

def main():

   n = int(input())

   a = input().split(maxsplit=n)

   a.sort(key=lambda x: sum(map(int, x)), reverse=True)

   print(*a)

if __name__ == "__main__":

   main()

Объяснение:

это python

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика