Сортировка. метод выбора. напишите программу, которая сортирует массив и находит количество различных чисел в нем. пример: массив: 5 3 4 2 1 6 3 2 4 после сортировки: 1 2 2 3 3 4 4 5 6 различных чисел: 6 нужно . ,люди ,добрые

saya8282 saya8282    2   27.08.2019 17:30    7

Ответы
tyrko24111995 tyrko24111995  03.08.2020 10:06
Begin
  var c, min, imin: integer;
  c := 0;
  var ar := readarrinteger('Массив:',readinteger());
  for var i := 1 to ar.Length do
  begin
    min := ar[c];
    imin := c;
    for var j := c to ar.Length - 1 do
    begin
      if(ar[j] < min) then
      begin
        min := ar[j];
        imin := j;
      end;
    end;
    swap(ar[c], ar[imin]);
    c := c + 1;
  end;
  write('После сортировки: ');
  ar.Println;
  write('Различных чисел: ',ar.Distinct.Count);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика