Снужно написать программу для паскаля возведения числа а в степень n/

milashkamilana2005 milashkamilana2005    2   30.06.2019 16:50    2

Ответы
sasha3756245 sasha3756245  24.07.2020 09:36
Program zadacha;
var a,b,c : integer;
begin
c:=1;
write('Введите число ==> ');
readln(a);
write('Введите его степень ==> ');
readln(b);
while b<>0 do begin
c:=a*c;
b:=b-1;
end;
write('степень числа ==> ',c);
end.
ПОКАЗАТЬ ОТВЕТЫ
cemikhadam cemikhadam  24.07.2020 09:36
program stepen;
uses crt;
var a,n,i,p : integer;
begin
write('Введите число a=');
readln(a);
write('Введите степень числа n=');
readln(n);
p:=1;
for i:=1 to n do
p:=p*a;
write('Число а в степени n = ',p)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика