tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сложное по информатике: нужно
Сложное по информатике: нужно написать программу на паскале, не используя if, then, else, с таким результатом: введите число если число четное, то вывести 10; если нечетное, то вывести -10
ademausag
2 03.08.2019 18:40
5
Ответы
166niko
03.10.2020 20:44
Var a:integer;
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.
Пример:
a = 28
10
ПОКАЗАТЬ ОТВЕТЫ
Nicner120
03.10.2020 20:44
Var
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kvaki257989
09.07.2019 06:40
Найти произведение чисел введеных с клавиатуры, пока не будет введен 0...
Nastlerfight
09.07.2019 06:40
Составьте программу, которая заполняет массив а [1..10] случайными целыми числами в диапазоне от 1 до 10,затем преобразовывает его, увеличивая все элементы с чётными...
Одиннадцатиклассниц9
09.07.2019 06:40
Представьте себе, что вы проектируете сайт своей школы. какую информацию вы бы поместили на главной странице?...
DashkaPypsik
20.05.2020 14:42
Функция для построения поверхности,которая вызывает ассоциацию с каким либо предметом...
Shokzzz
20.05.2020 14:42
Корни и квадраты Чему будет равно выражение, записанное на языке программирования Паскаль? sqrt(12 * (51 + 7) - 20)...
nastyakarina112
20.05.2020 14:41
HTMLУчитель говорит, что тут синтаксическая ошибка ОЧЕНЬ почему картинка не загружается?...
murad2097
20.05.2020 14:40
Дано: a = 9D16. Запишите это число в двоичной системе счисления...
dimatitov1428dimasik
23.12.2020 01:44
Только 3 задания дам если можете 4 тоже зделайте мне нужна 3 задания если вы бла бла вам бан по быстрей...
дариякаримова
23.12.2020 01:49
Определите значение на выходе данной схемы при А=0 и В=1...
sasha1836
13.06.2019 01:20
Вкаком устройстве компьютера производится обработка информации? клавиатура,монитор,внешняя память,процессор....
Популярные вопросы
Реши жирафы в зоопарке дали дневную порцию овощей - 11 кг и фруктов...
3
Кто друзья вакулы из ночь перед рождеством?...
1
Определить количество вещества so2 массой 100 грамм...
3
Велосипедист 3часа проехал по песчаной дороге со скоростью 7км/ч...
1
Решите уравнения 1)х: 12=17 2)561: х=11 3)17х-9х=672...
2
Определите силу тяжести, действующую на 5 л воды...
2
Гипотенуза=11см катет a=9 найти катет b ответьте двумя...
3
Какие остатки могут получиться при делении некоторого числа :...
2
Звук (т) треба вимовлять в обох словах рядка. а телефон фестиваль...
3
Соотнести цифры подходящие к классу млекопитающие млекопитающие...
3
begin
write('a = ');
readln(a);
writeln(-20*(abs(a) mod 2)+10);
end.
Пример:
a = 28
10
n: integer;
res: boolean;
begin
readln(n);
res:=odd(n);
case res of
true: writeln('-10');
false: writeln('10');
end;
end.