Склавиатуры вводят слово.составить программу ,которая: а)определяет количество символов в нём б)проверяет,не ли первая и последняя буквы слова в)выводт на экран первый,второй и последний символы г)определяет,чётно или нечётно количество символов в нём

Вайсбергггг Вайсбергггг    2   15.03.2019 08:30    9

Ответы
Rairaku24 Rairaku24  25.05.2020 12:02

uses crt;
var s: string;
begin
writeln('Напишите слово');
readln(s);
writeln(length(s) ,' символов');

writeln(s[1] ,' первый символ ', s[2] ,' второй символ ', s[length(s)] ,' последний символ');

if (s[length(s)] = s[1]) then
begin
writeln('совпадают');
end
else writeln('не совпадают');
if (length(s) mod 2 = 0) then
begin
writeln('четное кол-во');
end
else writeln('не четное');

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика