tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Склавиатуры вводится натуральное
Склавиатуры вводится натуральное число n. программа выводит максимальную нечетную цифру числа. написать программу на паскале.
ника43556
1 06.08.2019 00:10
7
Ответы
Варя1милаха
04.10.2020 00:07
Var
max, n, t: integer;
begin
readln(n);
max := -1;
while n > 0 do
begin
t := n mod 10;
if (t mod 2 = 1) and (max < t) then
max := t;
n := n div 10;
end;
if max = -1 then writeln('Нет такого числа')
else
writeln('Max = ', max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
олеся788
20.05.2021 10:08
Постройте логическую схему, соответствующую выражению...
elena1234569
20.05.2021 10:08
Дано текст. Для кожного із слів вказати, скільки разів воно зустрічається у тексті. НАПИСАТИ У С++...
Ульяна3330
20.05.2021 10:07
укажи к какому информационому процессу относятся перевод текста с английского языка на русский информации...
sofiaivkina84
20.05.2021 10:07
Запиши команды для исполнителя Чертёжник, чтобы можно было изобразить замкнутую геометрическую фигуру, положение вершин которой на координатной плоскости определяется парами чисел...
Мухамед5Ли
20.05.2021 10:07
5. У исполнителя Вычислитель имеются две команды: 1) прибавь 1 2) умножь на I (I – неизвестное натуральное число; I 2). Выполняя первую из них, Вычислитель прибавляет к числу на экране...
закро
20.05.2021 10:06
Составьте алгоритм c++(13)N=20...
asdsssssssssss124
05.05.2021 19:27
5. Запиши в двоичном коде числа, представ тичном коде: 79, 103, 69, 73, 117, 83, 1216. Запиши единицы измерения информации.1 байт1 кбайт (килобайт) =1 Мбайт (мегабайт) =1 Гбайт (гигабайт)...
zarya0207
09.04.2020 16:25
Определи основание системы счисления числа 172 (8)...
katya2562
09.04.2020 16:30
Определи получения графического цифрового изображения, выбрав верные ответы. ксерокс получение из сети Интернет получение по IP-адресу использование графических планшетов...
Никалкова
23.12.2020 14:47
Фрагмент это..А) часть текста Б) Набор абзацевВ) А,Б...
Популярные вопросы
Равные обыкновенные дроби среди дробей 2/9; 3/11; 4/27; 9/22; 6/27; 15/55; 16/44...
1
Велосипедист за первые 5с проехал 50м за следующие 10с -200м и за последение 30...
2
Напишите структурные формулы веществ 2-метилпентан и 2,3,4,5-тетраметилгескан...
2
Пруд зарастает водяными лилиями. на первый день выросла одна лилия, на второй день...
1
Расположить в порядке убывания 9/17,13/24,0,52,1/2 заранее ....
2
Напишите структурные формулыа) 3,3 диметилпентана б) 2,3,4-триметил-3-этилпентана...
1
Из слова калькулятор выбрали одну букву.какова вероятность что это буква л?...
2
Найдите a, если 1)10: a=4: 2 2)a: 5=1,6: 1 3/5 3)9: 3=a: 6...
1
Как правильно написать решение и ответ...
1
Как связаны слова в первой паре, и вставить пропущенное слово во вторую пару 1)...
2
max, n, t: integer;
begin
readln(n);
max := -1;
while n > 0 do
begin
t := n mod 10;
if (t mod 2 = 1) and (max < t) then
max := t;
n := n div 10;
end;
if max = -1 then writeln('Нет такого числа')
else
writeln('Max = ', max);
end.