Синформатикой ( , с блок схемами и самой программой) 1.предположим, фирма заработала какую-то сумму денег- эту сумму запросите у пользователя. по законодательству из этой суммы следует перечислить в налог 23%. далее 39% идет на зарплату. составьте программу, которая рассчитает, какую сумму получит пользователь после выплаты всех налогов и зарплаты. 2. составьте программу, которая позволит для любых заданных дробных чисел ( их нужно запросить у пользователя) найти их целые части, сумму этих целых частей. 3. составьте программу, которая по заданным сторонам треугольника( их нужно запросить у пользователя) определяет его площадь. напомню, что площадь можно вычислить по формуле герона s= квадратный корень от (p*(p-a)*(p-b)*(p- где p- полупериметр, a,b,c- стороны треугольника, которые надо запросить. результат выведите с двумя знаками после запятой.

AlzhanovSalavat AlzhanovSalavat    3   21.08.2019 16:40    7

Ответы
2003Саша 2003Саша  26.08.2020 07:57
{1}
var
n: integer;
begin
write ('Введите заработанную сумму: ');
readln (n);
write ('Вы получите: ', (n*0.77)*0.61)
end.

{2}
var
a: array of double;
n, i: byte;
sum: longint;
begin
write ('Введите кол-во дробных чисел: ');
readln (n);
setLength (a, n);
   for i:=0 to n-1 do
   begin
   write ('Введите ', i+1, ' число: ');
   readln (a[i]);
   end;
 for i:=0 to n-1 do
 begin
 writeln ('Целая часть ', i+1, ' числа: ', trunc(a[i]));
 inc (sum, trunc(a[i]));
 end;
write ('Сумма целых частей: ', sum);
end.

{3}
var
a, b, c, p: double;
begin
write ('Введите стороны треугольника: ');
readln (a, b, c);
  if (a>=(b+c)) or (b>=(a+c)) or (c>=(b+a)) or (a<=0) or (b<=0) or (c<=0) then
  write ('Такой треугольник не существует')
  else begin
   p:=(a+b+c)/2;
   write ('Его S = ', sqrt (p*(p-a)*(p-b)*(p-c)):7:2, ' ед^2' );
  end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика