Синформатикой( два номера) программу, которая определяет попадает ли точка с вводимыми с клавиатуры координатами, в заданную область(окружность). см припрепленный файл.и вторая : напишите программу, которая определяет попадает ли точка в заданную область(см файл)
Язык СИ:
1.
#include<stdio.h>
#include<math.h>
int main(){
long double x,y;
scanf("%Lf%Lf",&x,&y);
printf("%s\n",sqrtl(x*x+y*y)<=2?"yes":"no");
return 0;
}
2.
#include<stdio.h>
#include<math.h>
int main(){
long double x,y;
scanf("%Lf%Lf",&x,&y);
printf("%s\n",-2<=x && x<=0 && -2<=y && y<=0?"yes":"no");
return 0;
}