Сильно на языке pascalabc.net или turbopascal: 1) разработать программу циклической структурой,используя цикл с параметром. дано действительное число х, натуральное число n. написать программу, которая вычисляет сумму последовательности, заданной формулы x^1/1! +x^2/2! +x^3/3! ++x^n/n!

bezheveck bezheveck    1   31.07.2019 12:10    1

Ответы
наука28 наука28  31.07.2020 23:54
//PascalABC.NET 3.1 сборка 1239
begin
    var x := ReadReal('x =');
    var s := 0.0;
    var a := 1.0;
    
    for var i := 1 to ReadInteger('n =') do
    begin
        a *= x / i;
        s += a;
    end;
    writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика