Си++ составить программу, вычисляющую и выводящую все члены числового ряда 1, 1/2! ,1/3! , …,1/n! , значение которых превышает 10-5.

LeeAddon LeeAddon    2   22.05.2019 09:00    9

Ответы
standartny1ychenik standartny1ychenik  01.10.2020 06:26

#include<iostream>

using namespace std;
long double fac(int N)
{
if(N < 0) // если пользователь ввел отрицательное число
return 0; // возвращаем ноль
if (N == 0) // если пользователь ввел ноль,
return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)
else // Во всех остальных случаях
return N * fac(N - 1); // делаем рекурсию.
}
int main()

{
int N;
cout << "enter N: " ;
cin >> N;
for(int i = 0; i < N; i++)
cout << "a[ " << i << " ] = " << 1/fac(i) << endl;
}

 

данная программа вычисляет  значения ряда, до N-го члена ряда

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика