Си ++, , , нужно написать программу с оператором while, которая будет включать пользовательскую функцию для вычисления значения z

Бека672 Бека672    1   05.11.2019 23:47    19

Ответы
оксана754 оксана754  10.10.2020 11:28

Исходник ниже.

Объяснение:

#include <iostream>

#include <cmath>

using namespace std;

int main(){

   //"\t" - табуляция

   //fixed - для вывода фиксированного количества знаков после запятой у вещественного числа

   cout << "x\t\ty\t\ta\t\tb\t\tz" << endl;

   double x = 0.5;

   while(x <= 1.9){

       double y = 0.1;

       while(y <= 0.2){

           double a = cos(x*x*x - sqrt(y));

           double b = pow(x * y * y, 1.0 / 3);

           double z;

           if (a > b){

               z = a;

           }

           else{

               z = b;

           }

           cout << fixed << x << "\t" << y << "\t" << a << "\t" << b << "\t" << z << endl;

           y += 0.05;

       }

       x += 1.1;

   }

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика