Сформируйте одномерный массив из n-элементов (значения элементов зависит от порядкового номера массива и вычисляется по формуле ( i+5)^2). параметр n должен задавать пользователь. напишите программу, вычисляющую сумму значений элементов одномерного массива и среднее арифметическое введенных n чисел. вывод оформите в строку через пробел.

Ggggggghhhj Ggggggghhhj    3   26.05.2019 07:20    2

Ответы
tropika33 tropika33  22.06.2020 17:19
Var
  a: array[1..100] of integer;
  i, s, n: integer;
begin
  readln(n);
  for i := 1 to n do begin
    a[i] := (i + 5) * (i + 5);
    write(a[i],' ');
    s := s + a[i];
  end;
  writeln;
  writeln(s, ' ', s / n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Vikamolch11 Vikamolch11  22.06.2020 17:19
Uses crt;
const m=1000;
var a:array[1..m] of integer;
i,s,n:integer;
sr:real;
begin
readln(n);
writeln;
s:=0;
for i:=1 to n do
begin
a[i]:=(i+5)*(i+5);
writeln(a[i]);
s:=s+a[i];
end;
writeln;
sr:=s/n;
writeln(s,' ',sr);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика