tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сформировать двумерный
Сформировать двумерный массив а (7x7). вывести его как таблицу и найти сумму элементов главной диагонали.
verinikamusia
2 18.07.2019 00:50
2
Ответы
enotkcovi
03.10.2020 06:46
Var
A : array[1..7,1..7] of Integer;
i,j,s : Integer;
Begin
s:=0;
For i:=1 to 7 do
Begin
For j:=1 to 7 do
Begin
A[i,j]:=Random(100);
If i=j then s:=s+A[i,j];
Write(A[i,j]:4);
end;
Writeln;
end;
Write('Сумма элементов главное диагонали: ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Evgenevgenevgen
15.04.2020 10:28
РАЗЫГРЫВАЕМ ответьте на во Какая часть игры Silent Hill считается ремэйком первой части? a.Silent Hillsb.Silent Hill 3c.Silent Hill downpour d,Silent Hill 4: The roome.Silent...
studentka87
14.12.2021 10:19
1) Правильно ли утверждение: «С системной программы MS PAINT, которая является графическим редактором – мы можем делать рисунки.» 2) Правильно ли утверждение: «Система...
TanyaSha300
28.03.2020 11:37
Очень Гении программы КуМир написать программу (КуМир Чертёжник) чтобы получилась следующая фигура:...
igor4321tryutr
28.03.2020 11:37
Переведите с Паскаля в Java const m = 20;{максимальное количество элементов} var a: array[1..m] of real; i, n: integer; begin Write( Введите количество элементов (от...
dekok584p08crj
28.03.2020 11:37
Пользователь вводит 3 числа. Найти их сумму, определить кратна ли эта сумма числу 7 написать на языке си...
Дашута001
16.11.2020 11:55
4. Какую информацию о людях Двуречья даёт этот документ? 5. Какие сведения о жизни людей можно узнать из этого мифа?сам текст: Однажды рассердились боги на людей и...
Ариша337
16.11.2020 11:55
Ұлы Дала деп қай аймақты айтамыз ...
Zipchik
16.11.2020 11:55
2. Представителями отряда грызунов является: 1) еж2) бобр3) тушканчик4) куница5) крысаа)1,3,5б)2,3,5в)1,2,4г)3,4,5...
Роннилав
16.11.2020 11:55
Вопрос: Сопоставьте название зон ЧС с их описанием. Укажите соответствие для всех 6 вариантов ответа: 1) Зона локальных ЧС 2) Зона ЧС муниципального характера 3) Зона...
Azilll
16.11.2020 11:55
Какая эмоциональная окраска в стихотворение Листья (настроение которым проникнуто стихотворение)...
Популярные вопросы
Напишите сочинение по рассказу в дурном обществе...
2
Скорость одного пешехода 4 км.ч,а скорость другого пешехода 6км.ч.за...
3
Составьте диалог делового характера,между представителем школьного...
1
ответить на вопрос. вы хотели бы прочитать книгу рэй брэдбера ?...
3
ответить на вопрос почему памятники архитектуры относятся жедовром...
2
Водяной построил кикимор в колонну по 3, при этом кикимора дуся...
3
Составьте текст из 4 бессоюзных предложений с разными знаками препинания...
3
Please help! покладіть дієслова в дужках в present perfekt 1. he...
1
Биография осипа мандельштама кратко...
1
Один комбайн убирал с поля картофель в течение 19 ч, а затем в...
3
A : array[1..7,1..7] of Integer;
i,j,s : Integer;
Begin
s:=0;
For i:=1 to 7 do
Begin
For j:=1 to 7 do
Begin
A[i,j]:=Random(100);
If i=j then s:=s+A[i,j];
Write(A[i,j]:4);
end;
Writeln;
end;
Write('Сумма элементов главное диагонали: ',s);
end.