Сделать программу на паскале.
Задание!Написать программу, которая бы запрашивала возраст женщины и сообщала, сколько лет ей осталось до
пенсии, либо что она уже пенсионер.

Anna3367171 Anna3367171    2   28.04.2020 10:26    12

Ответы
1o10019soos 1o10019soos  14.10.2020 00:15

program jjjfd;

const n=60;

var

i: integer;

begin

writeln('Введите свой возраст');

readln(i);

if i>n then writeln ('Вы на пенсии')

else writeln('Вам осталось ', n-i, ' лет до пенсии');

readln;

end.

Объяснение:

program jjjfd;

const n=60; // константа, обозначающая возраст выхода на пенсию

var

i: integer;

begin

writeln('Введите свой возраст');

readln(i); // считываем с клавиатуры переменную i

if i>n then writeln ('Вы на пенсии') // если введённое число больше 60, печатаем, что мадам на пенсии

else writeln('Вам осталось ', n-i, ' лет до пенсии'); // в случае, если мадам ещё нет 60, печатаем сколько лет до пенсии ей осталось

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика