Сделать по программированию в pascal. 1. найти произведение всех элементов массива размерностью n (если элемент равен 0, то пропустить). 2. найти максимальный по модулю элемент матрицы. напечатать его значение и индексы.

1Юліана1 1Юліана1    3   12.09.2019 16:50    3

Ответы
Дарья0007 Дарья0007  07.10.2020 10:03
1)
const
  N = 5;//Размерность массива

var
  m: array[1..N] of integer;

begin
  var pr := 1;
  for var i := 1 to N do
  begin
    read(m[i]);
    if m[i] <> 0 then pr := pr * m[i];
  end;
  writeln(pr);
end.

Пример:
Входные данные:
1 2 3 0 5
Выходные данные:
30

2)
const
  N = 3;//Размерность матрицы

var
  m: array[1..N, 1..N] of integer;
  i, j: integer;
  rec: record
    mmax: integer = -(maxint);
    ind: record
      i: integer;
      j: integer;
    end;
  end;

begin
  for i := 1 to N do
    for j := 1 to N do
    begin
      read(m[i, j]);
      if abs(m[i, j]) > rec.mmax then begin
        rec.mmax := abs(m[i, j]);
        rec.ind.i := i;
        rec.ind.j := j;
      end;
    end;
  writeln('Максимальный по модулю элемент матрицы ', rec.mmax, '(', rec.ind.i, ';', rec.ind.j, ')');
end.

Пример:
Входные данные:
1 2 3
4 5 -9
7 8 6
Выходные данные:
Максимальный по модулю элемент матрицы 9(2;3)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика