сделать :

1)Исправить ошибки в программе , которая определяет количество отрицательных элементов .массива:

Program M;

Const

N=10;

Var

A: Array[1..N] of integer

I,k:integer;

Begin

For I:=1 To N Then

A[I]:=Random100-50;

if A[i]<0 do k:=k+1

End;

Write(k=,k);

End

2)Расставить в правильном порядке строчки программы , которая находит сумму всех четных элементов массива :

Program M;

constN=10;

Var

S:=0;

I,s : integer;

Begin

If A[i] mod 2=0 then S:=s+A[i];

A[i]:= Trunc Random (101)-50;

End;

For I:=1 To N Do begin

A:Array [1..N] of integer;

Write('s=',s);

End.

3)Написать программу , которая посчитает сумму заработанных командой из 10 человек интеллектуальном турнире по химии . для каждого участника указать рандомными числами в диапазоне от 5 до 20

mirt10 mirt10    1   03.03.2020 16:19    26

Ответы
carollabelle carollabelle  11.10.2020 17:51

1) Program M;

Const N=10;

Var A: Array[1..N] of integer;

I,k:integer;

Begin

For I:=1 To N do begin

A[I]:=Random100-50;

if A[i]<0 then k:=k+1

End;

Write(k=,k);

End.

2)Program M;

const N=10;

Var A:Array [1..N] of integer;

I,s : integer;

Begin

S:=0;

For I:=1 To N Do begin

A[i]:=Random (101)-50;

If A[i] mod 2=0 then S:=s+A[i];

End;

Write('s=',s);

End.

3) Program chemistry;

Const N=10;

Var A: Array[1..N] of integer;

S:integer;

Begin

For I:=1 To N do begin

A[I]:=Random(16)+5;

s:=s+a[i];

End;

Write(s=,s);

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика