tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сблок схемы или паскаля составьте
Сблок схемы или паскаля составьте алгоритм для решения следующей : среди n произвольных вещественных чисел найдите количество не равных нулю.
henriksenkids
3 09.08.2019 17:00
1
Ответы
312645
09.08.2020 07:54
Var n,i,k:integer;
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
ПОКАЗАТЬ ОТВЕТЫ
788SOS111
09.08.2020 07:54
Var n,i,k:integer;
a:array[1..1000] of real;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<>0 then inc(k);
write(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ДанькоДенис2018
21.06.2019 14:40
Вчем разница между режимом отображения формул и режимом отображения значений?...
lyuda29m
21.06.2019 13:45
Дано значение угла α в радианах (0 α 2·π). определить значение этого же угла в градусах, учитывая, что 180° = π радианов. в качестве значения π использовать 3.14....
SHIRINA11
06.05.2020 10:16
Программе используется одномерный целочисленный массив A с индексами от 1 до 10. Значения элементов равны 4; 2; 5; 6; 7; 7; 7; 5; 5; 9 соответственно, т.е. A[1] = 4; A[1] =...
akopovaliza2003
06.05.2020 10:16
Опишите инструменты и их функции ...
NickWorld
26.01.2021 11:32
С ИНФОРМАТИКОЙ. Четвертое задание очень нужно...
WDGa5ter
26.01.2021 11:31
составьте программу заполнения и вывода на экран целочисленного массива а из десяти элементов, каждый из которых равен: своему индексу и квадрат инлекса...
manenkova1997
26.01.2021 11:31
Что такое байт сколько байтов составляет 1 килобайт...
Алісія
27.05.2019 14:50
Определите двоичный код строчной буквы п по её десятичному коду -239 (с решением)...
olgaerchik
27.05.2019 14:50
Заменить каждый символ * в строке на cимвол ?...
Dasha2302
09.04.2021 10:26
С питона сделайте программу, которая выводит среднее двух чисел...
Популярные вопросы
Втреугольнике abc сторона bc=8 см, угол a =30° , а угол c=45°. найти: ab...
2
Постройте график линейной функции у=-2х-2...
1
Решить пример 4 4 4 4=10 расставить знаки чтобы получилось равенство?...
2
Сзабачами. мирасу 9 лет.его возраст составляет 25%возраста отца,а возраст...
3
Если назывным предложением называется односоставное предложение с главным...
3
Впервом овощехранилище на 5.6 т. картофеля больше чем во втором а в двух...
2
Сколько будет 7десятков тысяч,а сотен на 3 меньше,чем десятков тысяч...
3
Разбор глаголов отцвела выплыло зеленеет как часть речи...
2
Составить 10 вопросов одноклассникам...
1
Папоротники,хвощи,плауны.размножение папоротников...
2
a:array [1..50] of real;
begin
write('Введите целое N = '); readln(n);
for i:=1 to n do
begin
write('a[',i,'] = '); readln(a[i])
end;
k:=0;
for i:=1 to n do
if a[i]<>0 then k:=k+1;
writeln('k = ',k)
end.
a:array[1..1000] of real;
begin
readln(n);
for i:=1 to n do
read(a[i]);
for i:=1 to n do
if a[i]<>0 then inc(k);
write(k);
end.