С1. составить алгоритм и написать программу на вычисление скорости или пути , при условии , если t< 3 часов , тогда вычисляем скорость иначе путь . каждую строку программы прокомментировать . входные данные t = 80 мин.

Pryanya11 Pryanya11    2   08.06.2019 04:20    2

Ответы
arrrrrrrrr1 arrrrrrrrr1  01.10.2020 21:59
Алгоритм:
Начало
Ввод t
Если t>1 часа, то 
начать выполнение операторов
ввод S;
V=S/t;
вывод V
закончить выполнение операторов
иначе 
начать выполнение операторов
ввод V;
S=Vt;
вывод S;
закончить выполнение операторов

Var S,V,t:integer;
begin
read(t);
if t>1 then
begin
read(s);
v:=s/t;
writeln('Скорость=',v);
end
else
begin
read(v);
s:=v*t;
writeln('Расстояние=',s);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика