С1. составить алгоритм и написать программу на вычисление площади или периметра прямоугольника , при условии, если а < b , тогда вычисляем периметр , иначе площадь . каждую строку программы прокомментировать . входные данные а=10 , b=8 решить 9 класс

alinavolk93ozs1oc alinavolk93ozs1oc    2   07.06.2019 23:40    2

Ответы
Тимур2020 Тимур2020  07.07.2020 12:52
Более красивый вариант) 

Program N_1;                         //Название программы
Var a,b,c:integer;                   //Переменные
BEGIN
Writeln('Введите длину и ширину прямоугольника');  //Вывести данную строку
readln(a,b);                         //Считать a и b
if a<b                                 //Если a<b
then begin                          //то найти периметр
c:=(a+b)*2;
Writeln('Пириметр= ',c)       //и вывести его
end
else begin                         //Если a>b
c:=a*b;                             //то найти площадь
writeln('Площадь= ',c)       //и вывести ее.
end;
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика