tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
С++ занести в массив значения
С++ занести в массив значения функции f(x,y)=1/(x+y), 0≤x≤35, 0≤y≤25 и вывести его на экран (желательно с использованием функции "rand")
greatdannil
2 29.08.2019 07:20
1
Ответы
mikki60
06.10.2020 02:25
//TDM-GCC 4.9.2
#include <iostream>
#include <cstdlib>
#include <locale>
#include <ctime>
inline double f(int x, int y)
{
double nm = 1000000 / (x + y);
nm /= 1000000;
return nm;
}
inline int r(int min, int max)
{
int num = min + rand() % (max - min);
return num;
}
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int x, y;
int a;
printf("Количество элементов в массиве?: ");
scanf("%d", &a);
double mass[a];
for(int i = 0; i < a; i++)
mass[i] = f(r(0,35),r(0,25)),
printf("%d-й элемент массива: %f\n", i+1, mass[i]);
do{
printf("\nВывести коннкретный элемент?(1-%d, 0 - выход): ",a);
scanf("%d", &a);
if(a)
printf("\t%d-й элемент: %f\n", a, mass[a-1]);
}while(a);
return EXIT_SUCCESS;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sokolovvw1
26.07.2019 14:40
Рисунок размером 64 на 3584 пикселей создан с использованием палитры из 8 цветов. сколько килобайт занимает в памяти рисунок без учёта сжатия?...
Заноза19
26.07.2019 14:40
Рисунок размером 768 на 96 пикселей создан с использованием палитры из 8 цветов. сколько килобайт занимает в памяти рисунок без учёта сжатия?...
max5569496
26.07.2019 14:40
Известна скорость машины v км\ч(вводится с клавиатуры). напечатать таблицу расстояний за время от 0 до 1 мин с шагом 10 секунд. команда вывода writeln. (написать программу)...
ramzinakadenbaeva
16.08.2019 15:30
Придумай два повествовательных предложения таких,чтобы одно из них было истинным , а другое-ложным...
helloVika1
16.08.2019 15:30
Скласти програму, що обчислює вартість покупки товарів одного типу з урахуванням знижок на деякі групи товарів (групи мають коди) та знижку 5%, якщо загальна сума покупки...
милан64488
16.08.2019 15:30
Икт. основы информатики . страница 51,51 83...
Nasty2Tyan3
16.08.2019 15:30
Как придумать 2 повествовательные предложения,2 побудительные предложения,2 вопросительные предложения ,2 восклицательные предложения...
Marka9696
23.04.2020 16:24
Реферат История развития компьютерной техники...
mazurenkoella
23.04.2020 16:24
что делать если Самсунг не запускается он в каком-то режиме Facktory mod...
SlonoMen
23.04.2020 16:24
ЧУВАКИ ВСЕ СЮДА ХЭЛП 7 класс...
Популярные вопросы
Можна друзі розділити на сто частин яблуко, але не можна розділити землю...
3
Автомобиль ехал 1 ч со скоростью 80 км ч затем0.5 ч стоял а потом ехал...
1
1.mother is in the kitchen,she (to make) some cakes. 2. i (to eat) porridge...
2
Как осуществляется дыхание у плоских червей ....
2
Напишите уравнения реакций касающихся свойств соляной кислоты (с металлами...
1
карл гаусс сделал свое первое открытие много лет назад....
3
На оси оy найдите точку, равноудаленную от точек а(4; 2; -1) и b(-1; 3;...
3
Напишите письмо н.в. гоголю от читателя произведения тарас бульба...
3
какие мысли и чувства вызывает у вас этот фильм? белый бим черное ухо....
2
Какое количество концентрации соли у человека?...
2
#include <iostream>
#include <cstdlib>
#include <locale>
#include <ctime>
inline double f(int x, int y)
{
double nm = 1000000 / (x + y);
nm /= 1000000;
return nm;
}
inline int r(int min, int max)
{
int num = min + rand() % (max - min);
return num;
}
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int x, y;
int a;
printf("Количество элементов в массиве?: ");
scanf("%d", &a);
double mass[a];
for(int i = 0; i < a; i++)
mass[i] = f(r(0,35),r(0,25)),
printf("%d-й элемент массива: %f\n", i+1, mass[i]);
do{
printf("\nВывести коннкретный элемент?(1-%d, 0 - выход): ",a);
scanf("%d", &a);
if(a)
printf("\t%d-й элемент: %f\n", a, mass[a-1]);
}while(a);
return EXIT_SUCCESS;
}