С) turbo pascal составить программу к : 'числа a,b и c называются "пифагоровой тройкой",если выполняется условие a*a+b*b=c*c отыщите все пифагоровы тройки среди чисел от 1 до n

vika02bel vika02bel    3   27.06.2019 06:10    6

Ответы
Shark238 Shark238  02.10.2020 12:56
Вот решение за O(n^3)
var
n,i,j,z:longint;

begin
read(n);

for i:=1 to n do
 for j:=1 to n do
  for z:=1 to n do
   if (i*i+j*j=z*z) then writeln(i,' ',j,' ',z);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика