С! нужно. составьте программу: дана таблица вещ таб b[1: 7]. замените каждый отрицательный элемент нулем. дана таблица вещ таб с[1: 10]. найдите максимальный элемент таблицы.

маша3055 маша3055    2   07.10.2019 07:00    3

Ответы
adeluka5 adeluka5  10.10.2020 01:06

Первая часть

Program n_1;

var i:integer; B: array[1..7] of real;

begin

   for i:=1 to 7 do begin

       read(B[i]);

       if B[i]<0 then B[i]:=0;

   end;

   for i:=1 to 7 do write(B[i]:0:5, ' ');

end.

Вторая часть

Program n_2;

var i:integer; a:real; C: array[1..10] of real;

begin

   for i:=1 to 10 do begin

       read(C[i]);

   end;

   a:=C[1];

   for i:=1 to 10 do if (C[i]>a) then a:=C[i];

   writeln(a:0:10);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика