:с нужно составить алгоритм на языке программирования паскаль. дан массив, состоящий из 10 элементов. определите, сколько элементов этого массива имеют максимальное значение.
Var a:array[1..10] of real; b,c:integer; max:real; begin c:=0; writeln('Введите элементы массива'); for b:=1 to 10 do begin readln(a[b]); end; max:=a[1]; for b:=1 to 10 do begin if a[b]>max then max:=a[b]; end; for b:=1 to 10 do begin if a[b]=max then c:=c+1; end; writeln('Количество элементов,имеющих максимальное значение равняется ',c); end.
b,c:integer;
max:real;
begin
c:=0;
writeln('Введите элементы массива');
for b:=1 to 10 do
begin
readln(a[b]);
end;
max:=a[1];
for b:=1 to 10 do
begin
if a[b]>max then max:=a[b];
end;
for b:=1 to 10 do
begin
if a[b]=max then c:=c+1;
end;
writeln('Количество элементов,имеющих максимальное значение равняется ',c);
end.