С++ написать программу в которой генерируются 10 случайныx чисел в диапазоне от -5 до 30. посчитать среднее арифметическое чисел которые больше 10. (использовать цикл for)

асел9 асел9    1   23.08.2019 22:30    2

Ответы
AzatDit AzatDit  05.10.2020 15:25
#include <ctime>
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
srand(time(NULL));
int a[10];
int k,sum=0;
cout<<"исходные числа:"<<endl;
for(int i=0;i<10;i++)
{
a[i]=rand() % 36 - 5;
cout<<a[i]<<' ';
if (a[i]>10)
{
k=k+1;
sum=sum+a[i];
}
}
cout<<""<<endl;
cout<<"ср. арифм: "<<sum/k<<endl;
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
apiloota apiloota  05.10.2020 15:25
#include <iostream>
#include <random>
#include <ctime>

using namespace std;

int main() {
    int sum = 0;
    int cnt = 0;
    srand(time(0));
    cout << "Numbers: ";
    for (int i = 0; i < 10; i++) {
        int a = rand() % 36 - 5;
        cout << a << " ";
        if (a > 10) {
            cnt++;
            sum += a;
        }
    }
    cout << "\nAverage value = " << (double) sum / cnt;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика