tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Реьят напишите программу
Реьят напишите программу вычисления выражения: s=1! +2! +3! ++n! используйте функцию вычисления факториала
karinkuus
2 21.07.2019 11:30
16
Ответы
Алина007485
23.09.2020 08:54
Var n,i,s:integer;
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
ПОКАЗАТЬ ОТВЕТЫ
сельджан2
23.09.2020 08:54
// PascalABC.NET 3.1, сборка 1198 от 11.03.2016
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
sasha1860
11.06.2019 19:30
Turbo pascal. определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 42; b : = 14; a : = a div b; b : = a*b; a : = b div a;...
alishraup
11.06.2019 19:30
Примеры обмена обработки и хранения информации...
chcuvivhcyxu
11.06.2019 19:30
Запишите инструкцию, которая увеличивает на единицу значение переменной n....
Бегемотик397
11.06.2019 19:30
Вычислите площадь треугольника если основание и высота задана . информатика...
BaSfOr
11.06.2019 19:30
Перевсти 100 из восьмеричноц системы в десятичную систему счисления с решением...
дилирон1
11.06.2019 19:30
81 920 битов - это 1)80 килобайтов 2)10 килобайтов 3)8 килобайтов 4)1 мегобайт...
Алгебра111111111
11.06.2019 19:30
Перевод чисел из 10 сс в 2 сс (543, 950, 1025)...
AlinaTishka
11.06.2019 19:30
Решить на языке программирования pascal. в текущем месяце бригада в каждый последующий день работы выпускала на три изделия больше, чем в предыдущий. в первый день...
eliseyivanov9
11.06.2019 19:30
1.какие и органы чувст использует человек для восприятии информации? 2.каковы должны быть свойства информации, представленной в форме сообщения? 3. каковы должны...
Богдан2281667
11.06.2019 19:20
Правильный вариант набора текста в microsoft word: а) астры,тюльпаны; яблоки б) монитор,клавиатура,системный блок в) пойди туда - не знаю куда, принеси то - не знаю...
Популярные вопросы
Какие обьекты проходил магеллан во время своего путешествия?...
2
На двух полках было 48 книг.когда с первой полки сняли 10 книг,а...
1
Сладіть речення з поданих слів. підкресліть у ньому граматичну...
3
Сложите формулы солей калий хлорид, магний карбонату, цинк нитрата...
1
Cu+? =cuo что должен быть там 30...
2
Какие целые числа заключены : а) -3,2 и 5 б) -8,7 и -0,6 6 класс...
3
Растаяние между найближними гребенями волны 10м. какая частота...
1
Розвяжіть будьласка . із села до міста,відстань між якими 78км,...
1
Ребро куба равно 8 дм периметр куба...
1
Перевести текст с на . 3 класс. почему чак не обыкновенный щенок?...
1
function fact(k:integer):integer;
var j,f:integer;
begin
f:=1;
for j:=1 to k do f:=f*j;
fact:=f;
end;
begin
write('n='); readln(n);
s:=0;
for i:=1 to n do s:=s+fact(i);
writeln('s=',s);
end.
Пример:
n=5
s=153
function F(n:Integer):integer:=Range(1,n).Aggregate(1,(i,j)->i*j);
begin
Writeln(Range(1,ReadInteger('n=')).Select(x->F(x)).Sum);
end.
Тестовые решения:
n= 5
153
n= 10
4037913