РЕШИТЕ ЗАДАЧУ НА ПРОСТОЙ КОД - БЕЗ МАССИВОВ. ЗАРАНЕЕ ОГРОМНОЕ Определите сумму всех элементов последовательности, завершающейся числом 0. Формат входных данных Вводится последовательность целых чисел, оканчивающаяся числом 0 (само число 0 в последовательность не входит, а служит как признак ее окончания. Формат выходных данных Выведите ответ на задачу. Sample Input: 3 6 8 0 Sample Output: 17

Юлиана95631 Юлиана95631    1   14.08.2020 14:04    4

Ответы
залупа22223332323233 залупа22223332323233  15.10.2020 15:56

import java.util.Scanner;

class Main {

   static int getNumb() {

       Scanner numb = new Scanner(System.in);

       return numb.nextInt();

   }

   public static void main(String [ ] args) {

       int sum = 0;

       int x;

       while(true) {

           x = getNumb();

           if(x != 0) {

               sum += x;

           }

           else {

               break;

           }

       }

       System.out.print(sum);

   }

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика