tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решите в паскале. 1. найти
Решите в паскале. 1. найти и вывести на экран количество и сумму всех натуральных трехзначных чисел, кратных 25. 2. найти и вывести на экран количество четырехзначных чисел, сумма цифр которых равна 34.
ishohahdh
3 19.09.2019 02:40
7
Ответы
Oleganaft
08.10.2020 01:18
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (k,s):=(0,0);
Range(100,999,25).ForEach(t->begin k+=1; s+=t end);
Writeln('Количество ',k,', сумма ',s)
end.
Результат
Количество 36, сумма 19350
№2
function ds(n:integer):integer;
begin
Result:=0;
while n>0 do begin
Result+=n mod 10;
n:=n div 10
end
end;
begin
Writeln('Чисел: ',1000.To(9999).Where(t->ds(t)=34).Count)
end.
Результат
Чисел: 10
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
arsenboosss757
12.07.2019 09:00
Написать программу. ввести последовательность чисел размерностью n. в этой последовательности: найти минимальный и максимальный элементы. среднее арифметическое...
Маргошка55
12.07.2019 09:00
Запись числа 23 в некоторой системе счисления выглядит так: 212q. найдите основание системы счисления q. заранее )...
Irrishka2005
12.07.2019 09:00
А? ) запишите алгоритм циклического обмена значениями трёх переменных a,b,c. схема циклического обмена: a–›b–›c (цикл. от с снова к а ). например, если до обмена...
NotSmartBoy
27.05.2019 12:30
Всистеме счисления с некоторым основанием десятичное число 39 записывается в виде 1110 укажите это основание...
Dashka250715
27.05.2019 12:30
1.алфавит состоит из 25 букв, какое количество информации несет в себе одна буква такого алфавита? 2.какова длина слова, если при словарном запасе в 256 слов одинаковой...
0985440357
27.05.2019 12:30
Втаблице ниже представлена часть кодовой таблицы ascii: символ 1 3 x y z c z десятичный код 49 51 88 89 90 99 122 восьмеричный код 61 63 130 131 132 143 172 каков...
Zagadochnaya
27.05.2019 12:40
Какая ёмкость у: 1) гибкого магнитного диска, 2) жёсткого магнитного диска 3) cd 4) dvd 5) устройства на основе flash-...
Katerinkacat
27.05.2019 12:40
Дан радиус круга. вычислить площадь и длину окружности этого круга в паскале abc...
angeljulia20033
27.05.2019 12:40
Даны основание и высота равнобедренного треугольника. вычислить площадь и длины боковых сторон этого треугольника . в паскале abc...
Локи301
27.05.2019 12:40
Как представляется десятичное число 42.25 в двоичной системе счисления?...
Популярные вопросы
Три с сопротивлением r1 = 20 ком, r2 = 30 ком, r3= 40 ком соединены...
1
Площа поверхні куба дорівнює 24 см2. знайдіть об єм куба....
3
Свободный хлор может выделиться в результате взаимодействия...
2
Найдите значение выражение. все ! (√5-√2)^2...
3
Укажите слово в котором допускается варианты ударения искристый...
3
Кто изначально был машинистом на первой железной дороге общественного...
3
Прыгая с вышки высотой 10 м, спортсмен в воде испытывает среднюю...
2
Переведите на язык,поставьте в вопросительную и отрицательную...
2
Периметр треугольника abc равен 50 см . ав на 2 см больше стороны...
1
1)log4(9-x) 4 2)2^x +2^x+2 или = 20...
1
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (k,s):=(0,0);
Range(100,999,25).ForEach(t->begin k+=1; s+=t end);
Writeln('Количество ',k,', сумма ',s)
end.
Результат
Количество 36, сумма 19350
№2
function ds(n:integer):integer;
begin
Result:=0;
while n>0 do begin
Result+=n mod 10;
n:=n div 10
end
end;
begin
Writeln('Чисел: ',1000.To(9999).Where(t->ds(t)=34).Count)
end.
Результат
Чисел: 10