tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решите в паскаль двумя с использованием
Решите в паскаль двумя с использованием цикла с параметром и с предусловием. дано действительное число а, натуральное число n. вычислить: p = a (a+1)××(a+n-1)
VendyK
2 09.06.2019 04:50
4
Ответы
пипиша
08.07.2020 01:43
Var a,n,p,i:integer;
begin
write('Введите а и n: ');
readln(a,n);
p:=a;
for i:=1 to n-1 do
p:=p*(a+i);
writeln('ответ: ',p);
end.
var a,n,p,i:integer;
begin
write('Введите а и n: ');
readln(a,n);
p:=a;
while i<n-1 do
begin
i:=i+1;
p:=p*(a+i);
end;
writeln('ответ: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kitecat12
17.11.2020 19:51
Ребят очень это решить, на языке Паскаля максимально...
lebedevamilp00sr9
17.11.2020 19:51
С запроса получите список изданий объёмом меньше 200 страниц, автора с фамилией Манаков(а), с соавторами, и все издания в аннотации содержащие слово «магистрантов»,...
shmitko85
17.11.2020 19:51
перевести в двоичную шестнадцатеричную и восьмеричную системы счисления дробь 0.625...
Katuchka001
01.07.2019 10:08
даны два числа. если квадратный корень из второго числа меньше первого числа, тоувеличить второе число в пять раз.написать программу в delphi...
deneleslamov2
12.12.2020 17:16
Вам предоставлена программа на языке C , объяснить работу программы и объяснить значения функций. #include #include #define DELIM \t\n int main(void) { char buf[BUFSIZ],...
masha71301291
12.12.2020 17:18
выполнить, уже совсем запутался...
kubikrubik201
12.12.2020 17:25
Придумайте к этим словам , вопросы...
naila79
12.12.2020 17:26
что можно сделать с текстовым файлом один раз? переместить,переименовать, закрыть, удалить, открыть,создать....
y2334455
12.12.2020 17:28
192.45.12.3 маска 255.255.244.12 Вычислить Номер узла и номер сети...
hurremsultan30
12.12.2020 17:28
Таблица была отсортирована по ключу «Курс+Фамилия» по возрастанию. Запишите, в каком порядке будут выводиться записи таблицы (укажите только номера записей через запятую)...
Популярные вопросы
Complete these dialogues with the phrasal verb and a pronoun. -...
3
Нужно ответить на вопросы по расскажу Муму 1. почему Герасим утопил...
1
1)Тігін машинасының ең алғашқы жобасын кім ұсынды? 2)Тұрмыста қолданылатын...
2
Жилин Костылин Сходство Значение фамилии Внешность Отношение к...
1
3. Отгадай загадку. Определи лицо и число местоимений. Загадка:...
2
Кіші қазан қамтыған іс шаралар ( әр іс шараға қысқаша түсінік беру)...
2
Put the given verbs in the present simple...
1
Rewrite the sentences using capital letters.hello, i m aizere and...
1
Решите уравнения (827-532)....
2
Кіші қазан саясатының мақсаты ...
2
begin
write('Введите а и n: ');
readln(a,n);
p:=a;
for i:=1 to n-1 do
p:=p*(a+i);
writeln('ответ: ',p);
end.
var a,n,p,i:integer;
begin
write('Введите а и n: ');
readln(a,n);
p:=a;
while i<n-1 do
begin
i:=i+1;
p:=p*(a+i);
end;
writeln('ответ: ',p);
end.