tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решите,, в pascal ! для массива
Решите,, в pascal ! для массива из 20 элементов обнулить все отрицательные элементы и посчитать количество остальных.
Kerisha4
3 26.07.2019 03:00
1
Ответы
Вика2003033
15.09.2020 23:48
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ArrRandom(20,-50,50); a.Println;
var k:=0;
for var i:=0 to a.Length-1 do
if a[i]<0 then a[i]:=0 else Inc(k);
a.Println;
Print('k=',k)
end.
Тестовое решение:
-4 -25 17 -24 -32 -2 21 28 -14 37 -19 -3 -28 33 -27 -10 -30 7 21 -38
0 0 17 0 0 0 21 28 0 37 0 0 0 33 0 0 0 7 21 0
k= 7
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
SofyaIlina
30.11.2020 23:18
Это подготовка к экзамену...
диана2440
30.11.2020 23:20
Выполнение задания предусматривает написание программного кода на языке SQL, обеспечивающего создание БД. Написанный код должен быть выполнен. Преподавателю представляется и сам...
БарсукВася
30.11.2020 23:27
с информатикой var a, answer: integer; begin answer:=0; readln(a); while a 0 do begin if (a mod 8 = 0) and (a 9) and (a 100) then answer := answer + а; readln(a); end; writeln(answer)...
rasaka123
11.10.2019 15:17
Дайте полные развернутые ответы на вопросы: 1. как связаны мощность алфавита и разрядность двоичного кода, достаточного для кодирования всех символов этого алфавита? 2.дайте определение...
shm06
11.10.2019 15:24
Проект в лазарус. награда соответсвующа...
tiger071
11.10.2019 15:24
Синформатикой. напишите программу на паскале. дано натуральное число n (n ). если число четырёхзначное, то получите и выведите перевёртыш этого числа (3528 → 8253), иначе выведите...
DenisKazansev
11.10.2019 15:31
Сделайте алгоритм для программы кумир в среде черепаха вот фотки того чего сделать нужно...
Kit1gvore
23.05.2019 14:50
Краткая запись на клавише, предназначенной для переключения режимов вставка/замена ....
ildanmini086
23.05.2019 14:50
Клавиша при нажатии которую происходит отмена действия или выход из некоторого состояния...
reventon1
23.05.2019 14:50
Pascal abc вычислить сумму квадратов отрицательных чисел, стоящих на местах, кратных 3; подсчитать количество чисел, не принадлежащих промежутку [а, в)....
Популярные вопросы
Содержание военной,торговои,административной реформы К.Касымова...
2
Три натуральных числа, первое из которых равно 12, образуют арифметическую...
1
2) 5,86+11,82:(7-4,4)×3,5зарание...
3
2. Найди периметр прямоугольникаразными ...
1
Напишите мини сочинение на тему: «Мир без бытовой химии»...
1
По климатической карте определите средние январские температуры городов Петропавловск,...
2
Что такое верховой пожар?...
1
Что значит плотность воды 1000 кг / м³...
1
с химией При нагревании 10 г цинка и 10 г серы можно получить массу (г) сульфида...
2
Мүсірепов Пд Айтылым тапсырмалары1. Пристав, болыс сөздерінің мағынасы мұғалімнің...
3
begin
var a:=ArrRandom(20,-50,50); a.Println;
var k:=0;
for var i:=0 to a.Length-1 do
if a[i]<0 then a[i]:=0 else Inc(k);
a.Println;
Print('k=',k)
end.
Тестовое решение:
-4 -25 17 -24 -32 -2 21 28 -14 37 -19 -3 -28 33 -27 -10 -30 7 21 -38
0 0 17 0 0 0 21 28 0 37 0 0 0 33 0 0 0 7 21 0
k= 7