Решите сегодня на языке python Совпадающие начало и конец
Дана строка. Требуется найти самую длинную её подстроку, у которой совпадает первый и последний символы. Если подходит несколько подстрок, то выведите любую из них.

Входные данные

На вход подаётся одна строка из строчных латинских букв длиной не более 100 символов.

Выходные данные

Выведите ответ на задачу.

aluanakim aluanakim    3   15.03.2021 22:09    53

Ответы
khudobeidiana khudobeidiana  14.04.2021 22:10

s = input()

ans = ''

for i in range(len(s)):

   j = s.rfind(s[i]) + 1

   if j - i > len(ans):

       ans = s[i:j]

print(ans)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика