решите нужно очень (составить программу определения общего сопротивления электрической цепи при последовательном и параллельном соединении трех резисторов)

14ксенечка15 14ксенечка15    3   05.06.2020 20:47    10

Ответы
spikeeesz spikeeesz  15.10.2020 13:13

Объяснение:

const    

n = 10;    

r1 = 2;  

  r2 = 4;    

r3 = 3;

var  

  temp1, temp2: Real; begin  

  temp1 := r1 * ((n div 2) * (n + 1) + Ord(Odd(n)) * ((n div 2) + 1));    

temp2 := 2 * r2 * r3 / (r2 + r3);  

  WriteLn('R=',  (r1 + temp1 * temp2 / (temp1 + temp2) + r2):0:4);

end.

ПОКАЗАТЬ ОТВЕТЫ
ivanovaizl ivanovaizl  15.10.2020 13:13
                                     PascalABC.NET                                       beginvar n := ReadInteger('Введите количество резисторов:');var Rs := ReadArrInteger('Введите их сопротивления:',n);Writeln(NewLine, 'Общее сопротивление цепи равно:');Println(' при последовательном соединении -', Rs.Sum,'Ом');Println(' при параллельном соединении -', 1/Rs.Sum(r->1/r),'Ом');end.

или кратко:

beginvar Rs := ReadArrInteger(3);Println('послед:', Rs.Sum);Println('парал:', 1/Rs.Sum(r->1/r));end.

Пример работы:


решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл
решите нужно очень (составить программу определения общего сопротивления электрической цепи при посл
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика