Решите на Python Сумма квадратов По данному натуральному n вычислите сумму 12+22+32+...+n2. Входные данные Вводится натуральное число, не превосходящее 100. Выходные данные Выведите ответ на задачу. Примеры Ввод Вывод 3 14

Julia5415613614 Julia5415613614    3   16.08.2020 04:22    15

Ответы
Элаизааа Элаизааа  15.10.2020 15:57

Алгоритм: есть несколько решить эту задачу, смотря что от Вас требуется. Можно реализовать цикл, который каждый раз прибавляет к сумме квадрат следующего числа (сложность O(n)), а можно воспользоваться формулой 1^2+2^2+\ldots+n^2=\dfrac{n(n+1)(2n+1)}{6} и сразу выдать верный ответ (сложность O(1)).

Решение с цикла:

s = 0

for i in range(1, int(input())+1):

   s += i*i

print(s)

Решение с формулы:

n = int(input())

print(n*(n+1)*(2*n+1) // 6)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика