Решите:
Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трёхзначного числа х. Значение х ввести с клавиатуры.
Язык программирования Паскаль

euno euno    1   01.02.2021 00:25    8

Ответы
erke22 erke22  01.02.2021 01:00

Прости что не текстом :(


Решите: Дано целое трёхзначное число х. Составьте программу вычисления суммы и произведения цифр трё
ПОКАЗАТЬ ОТВЕТЫ
dshvedova06 dshvedova06  01.02.2021 01:00

var

s,pr,x : integer;

begin

readln(x);

x := abs(x);

s:= 0;

pr:= 1;

while x > 0 do

begin

s := s + x mod 10;

pr := pr * x mod 10;

x:= x div 10;

end;

writeln('S = ',s);

writeln('PR = ',pr);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика