решить задачу на Python,
Составить программу,которая в данной массиве из 40 случайных элементов от -5 до 5, которая определяет количество отрицательных элементов и находит сумму чисел, оканчивающихся на 4. Все элементы, оканчивающиеся на 4 выводит в порядке возрастания

Usdied Usdied    3   31.03.2020 17:08    1

Ответы
Sveta11111111Love Sveta11111111Love  12.10.2020 10:38

в условии не сказано, надо находить сумму чисел оканчивающихся на 4 в массиве из отрицательных элементов, или изначальном массиве. если узнаешь, отпиши, исправлю .

import random

number_list = [str(random.randint(-5, 5)) for n in range(40)]

negative_numbers = [i for i in number_list if int(i) < 0]

end_with_four = [number for number in number_list if number[-1] == '4']

amount = 0

for num in end_with_four:

   amount += int(num)

print('количество отрицательых элементов: ' + str(len(negative_numbers)))

print('сумма элементов оканчивающихся на 4: ' + str(amount))

end_with_four.sort()

for idk in end_with_four:

   print(idk, end = ' ')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика