решить задачу на Питоне, Рекурсия Задача
Напишите программу, содержащую рекурсивную функцию, которая по натуральному числу n, выводит все числа от n до 1. Основная программа должна содержать ввод исходных данных (число n) и вызов функции

Примеры
№ Входные данные Выходные данные
1 6 6 5 4 3 2 1
Запрещенные операторы: for;while;until

ulyanan260801 ulyanan260801    2   30.10.2020 01:05    17

Ответы
vgfhdijubvn vgfhdijubvn  29.11.2020 01:08

def allnumbers(n):

   if n == 0:

       return 1

   print(n, end=' ')

   allnumbers(n - 1)

n = int(input("Введите число n: "))

allnumbers(n)

Объяснение:

def allnumbers(n):  // Функция allnumbers, которая принимает аргумент n

   if n == 0:  // Если значение переменной n = 0

       return 1  // Выходим из функции

   print(n, end=' ')  // Выводим значение переменной n

   allnumbers(n - 1)  // Рекурсия

n = int(input("Введите число n: "))  // Вводим число n с клавиатуры

allnumbers(n) // Функция

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика