решить задачу на ПИТОНЕ! Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 2. Кол. Чисел не превышает 1000. Программа должна вывести одно число - максимальное число, оканчивающееся на 2

LOLgreen LOLgreen    3   16.05.2021 16:35    11

Ответы
alikachara alikachara  15.06.2021 16:38

import random

mass = []

masscomp = []

max = 0

for i in range(0, 1000):

   mass.append(random.randint(0, 1000000))

   masscomp = [int(x) for x in str(mass[i])]

   if (mass[i] > max and masscomp[len(masscomp) - 1] == 2):

       max = mass[i]

print(max)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика