tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить в паскале! на шахматной
Решить в паскале! на шахматной доске стоят черный король и три белые ладьи (ладья бьет по горизонтали и вертикали) . проверить, не находится ли король под боем.
ДашаШирова
1 01.07.2019 09:50
2
Ответы
maker1287
24.07.2020 19:23
const
n = 3; //Кол-во фигур
var
i : integer;
xk,yk : integer;
xl,yl : array [1..n] of integer;
r : boolean;
begin
//Задание координат
//
xk := 2; yk := 2; // Координаты короля
//Координаты ладьи
xl[1] := 1; yl[1] := 2;
xl[2] := 4; yl[2] := 6;
xl[3] := 5; yl[3] := 8;
//
r := false;
i := 1;
While (i <= n) and (not r) do
begin
if (xk = xl[i]) or (yk = yl[i]) then //Лежат на одной прямой
r := true;
i:= i +1;
end;
if r then
writeln ('Король под ударом')
else
writeln ('Король живет)');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Доминика671554
09.06.2019 07:50
Дана строка. каждую точку замените многоточием (т.е тремя точками). в чем беда? или совсем не правильно? var str : string; q: integer; k: string; begin writeln ( введите строку...
АНДрЕЙ12277777
09.06.2019 07:50
Чем отличпется функции кнопок сортировка на панели инструментов от команды данные-сортировка в exsel?...
5675566
09.06.2019 07:50
Pascal: в заданном массиве подсчитать число нулевых элементов и вывести на экран их индексы...
oljkejik
09.06.2019 07:50
1) собственное имя файла: а)задает пользователь б)задается программой автоматически 2) расширение: а)задает пользователь б)задается программой автоматически...
А22222222
09.06.2019 07:50
Протабулировать функцию e^2+x-2=0 на отрезке [1; 2]...
Аврораttt3783
09.06.2019 07:50
Сформулировать массив состоящий из четных чисел массива a()...
dobryninatonya
24.08.2019 21:10
Как называется сброс данных в компьютере? 4 буквы....
sveto4ckaklana
24.08.2019 21:10
Определите количество информации, содержащейся в черно-белой картинке размером 400*120 точек....
yana14102004
08.10.2019 06:20
Выполнить по информатике семакин 8 класс стр. 175 . 3...
Школьниқ
24.04.2021 07:38
Подсчитать наименьший положительный элемент двумерного массива от 1 до 20...
Популярные вопросы
1-тапсырма мәтінді мүқият оқып тақырыбы койыныз...
1
Заполните таблицу по комедии Д.И.Фонвизина Недоросль . Определите какому...
3
Какой природный ресурс обладает плодородием...
1
5. Вспомните слова 5 раздела, виды погоды. Выберите подходящее слово, опираясь...
3
Які проблеми порушив автор у повісті шанель...
2
выделение это одно из основных свойств всех живых организмов отнеситесь организмов...
1
«Ана-Жер-Ана» повесі желісімен түскен сахналық қойылымдар туралы дереккөздерден...
2
Sin(x +45°) - sin 45º cos x/cos(x - 45°) - cos 45º cos x...
1
перевод:Длина прямоугольника на 6 см больше ширины, а площадь - 187 см ^...
2
Task 3. Read the text and do the task, Tsunamis are a series of waves in...
2
n = 3; //Кол-во фигур
var
i : integer;
xk,yk : integer;
xl,yl : array [1..n] of integer;
r : boolean;
begin
//Задание координат
//
xk := 2; yk := 2; // Координаты короля
//Координаты ладьи
xl[1] := 1; yl[1] := 2;
xl[2] := 4; yl[2] := 6;
xl[3] := 5; yl[3] := 8;
//
r := false;
i := 1;
While (i <= n) and (not r) do
begin
if (xk = xl[i]) or (yk = yl[i]) then //Лежат на одной прямой
r := true;
i:= i +1;
end;
if r then
writeln ('Король под ударом')
else
writeln ('Король живет)');
end.