tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить в паскале из элементов
Решить в паскале из элементов массива d сформировать массив a той же размерности по правилу: первые 10 элементов находятся по формуле ai = di+i, остальные по формуле ai = di-i.
ИзмМалика
2 03.06.2019 21:50
5
Ответы
sinelena2018
01.10.2020 18:50
Const
n = 30;
var
i: integer;
a, d: array[1..n]of integer;
begin
for i := 1 to n do
begin
d[i] := random(100);
if i <= 10 then
a[i] := d[i] + i
else
a[i] := d[i] - i;
write(d[i]:4, ' ');
end;
writeln();
for i := 1 to n do
write(a[i]:4, ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
ART666999
01.03.2019 21:40
Начертите блок схему для вычисления площади круга радиусом r...
makskot69
18.03.2021 16:47
Написати програму піднесення до квадрату меншого із трьох заданих чисел А, В та С...
TvaylatHale123
18.03.2021 16:47
?ПОСТРОЙТЕ ТАБЛИЦЫ ЗНАЧЕНИЙ ДОЯ УКАЗАННЫХ ФУНКЦИИ x принадлежит [а,b], вводятся значения a,b и количество точек...
mrdanildanDan
18.03.2021 16:46
хотя-бы один файл сделать ......
ппппппп25
21.12.2020 10:43
1. Дан фрагмент программы, записанной языке программирования Паскаль. Определите значения переменных А и В после выполненияданного фрагмента.а:=1;for i:=1 to 3 dobegina:=a+i;b:=a*2:end;2....
ДанилКопейка
21.12.2020 10:43
Определите истинность логического высказывания...
полина2130
21.12.2020 10:43
В некотором каталоге хранился файл Принцесса_Монако. mp4. Имевший полное имя D:\оливье даан\Грейс Келли\Принцесса_Монако. mp4. В этом каталоге создали подкаталог Хичкок и Принцесса_монако....
polonnikovdanil
13.01.2021 20:33
Повідомлення про роль В.М.Глушкова в розвитку напрямів інформатики , пов язаним з використанням баз даних...
Сателла1
13.01.2021 20:27
У меня 2 аккаунта . Пришла смс о действиях 2 аккаунта. Я зашёл на него. Всё устранил. Потом обратно зашёл на первый аккаунт и все пароли удалилась Можно ли как-то восстановить данные?...
dashaklimova01
09.04.2020 17:09
Напишите программу для работы со списком из произвольного количества учеников (не больше 50). О каждом ученике запрашивается Имя, Отчество, Фамилия, возраст, номер и буква класса....
Популярные вопросы
Студенты изучают экономическую литературу, касающуюся создания и использования материальных...
2
Старшеклассники обучают младших школьников играть в компьютерные игры. Субъектом...
2
Примером влияния природных факторов на развитие общества является 1) создание памятника...
2
Определите нуклеотидный состав РНК, которая возникла в процессе транскрипции со...
1
Что из перечисленного характеризует современное западное общество 1) аграрный тип...
2
Верны ли следующие суждения о процессе глобализации современного мира А Развитие...
1
Загрязнение воздуха, связанное с ростом числа автомобилей, служит примером взаимосвязи...
3
С такого критерия, как совершенствование нравственности людей, можно показать прогрессивный...
3
Верны ли следующие высказывания об общественном прогрессе А Понятие «прогресс» и...
3
Верны ли следующие суждения о взаимосвязи сфер общественной жизни А Спад производства...
1
n = 30;
var
i: integer;
a, d: array[1..n]of integer;
begin
for i := 1 to n do
begin
d[i] := random(100);
if i <= 10 then
a[i] := d[i] + i
else
a[i] := d[i] - i;
write(d[i]:4, ' ');
end;
writeln();
for i := 1 to n do
write(a[i]:4, ' ');
end.