Решить в паскале 1. вводится число от 1 до 10. дать название этого числа (1 - один , 2 - два , …, 10 - десять); 2. вводится число от 1 до 7, определяющее день недели. дать название этого дня (1 - понедельник, 2 - вторник, …, 7 - воскресенье); 3. в спортивных соревнованиях шарик, кот матроскин, дядя фёдор и почтальон печкин заняли соответственно 1, 2, 3 и 4 места. составить программу, которая по номеру места выдаёт имя участника соревнований. 4. вводится число от 1 до 15. вывести данное число, записанное римскими цифрами (i, ii, iii, iv, v, vi, …., xv); 6. вводится число от 1 до 15. вывести данное число, записанное в двоичной системе счисления (1, 10, 11, 100, 101, …., 1111);

ghosts010 ghosts010    3   25.05.2019 05:50    4

Ответы
нури43 нури43  21.06.2020 06:15
Var a:integer;
begin
readln(a)
if a:=1 then writeln('1 - один');
 if a:=2 then writeln('2 - два');
 if a:=3 then writeln('3 - три');
 if a:=4 then writeln('4 - четыре');
. . .{по аналогии}
end.
2)Абсолятно то же самое что и в предыдущем номере, просто тепрь писать 1 - понедельник, 2 - вторник...
3)var a:integer;
if a:=1 then writeln('Sharik');
if a:=2 then writeln('kot');
if a:=3 then writeln('Fedor');
if a:=4 them writeln('Pechkin');
end.
4) и 6) выполняются по аналогии.
Если не понимаешь, я объясню в комментариях.
 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика