РЕШИТЬ В ПАСКАЛЬ Дана строка, состоящая из слов (разбитых пробелами) и строка символов. Необходимо выяснить, можно ли из символов строки 2 получить слова из строки 1. Если можно, то вывести эти слова, иначе вывести NO. (буквы из набора можно использовать несколько раз)

Входные данные

Строка содержащая слова через пробел и строка с набором букв

Выходные данные

Слова, которые можно получить из символов второй строки или слово NO

For example:

Input Result
hello i love you
ieohuyvl
hello
i
love
you

Vgenika Vgenika    2   24.12.2020 09:34    1

Ответы
Асель1139 Асель1139  23.01.2021 09:35

var s,s1,s2:string;

p,k:integer;

begin

readln(s);

s1:=s+' ';

while pos('  ',s1)>0 do delete(s1,pos(' ',s1),1);

while s1<>'' do

begin

p:=pos(' ',s1);

s2:=copy(s1,1,p-1);

delete(s1,1,p);

k:=1;

while pos(s2,s1)>0 do

begin

k:=k+1;

delete(s1,pos(s2,s1),p);

end;

if k=1 then writeln(s2);

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика