Решить по программированию, используя, а) оператор ветвления б) оператор цикла написать программу нахождения наибольшего из пяти чисел, вводимых с клавиатуры. pascal

fsks fsks    1   24.09.2019 02:40    5

Ответы
andriu12252 andriu12252  08.10.2020 13:55
Разветвляющийся алгоритм

Var a,b,c,d,e:integer;

Begin

Writeln('Введите значения переменных');

Readln(a,b,c,d,e);

If (a>b) and (a>c) and (a>d) and (a>e) tnen

Writeln('Наибольшее из 5 чисел ', a)

Else

If (b>a) and (b>c) and (b>d) and (b>e) tnen

Writeln('Наибольшее из 5 чисел ', b)

Else

If (c>a) and (c>b) and (c>d) and (c>e) tnen

Writeln('Наибольшее из 5 чисел ', c)

Else

If (d>a) and (d>b) and (d>c) and (d>e) tnen

Writeln('Наибольшее из 5 чисел ', d)

Else

Writeln('Наибольшее из 5 чисел ', e);

End.

Циклический алгоритм

Type

Vector=array [1..10] of integer;

Var m:integer;

a:vector;

i:byte;

Begin

Writeln('Введите значения переменных');

For i:=1 to 5 do

      Readln (a[i]);

For i:=1 to 5 do

If  a[i]>a[i+1] then

m:=a[i];

Writeln('Наибольшее число ', m);

End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика