tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Решить по pascal. дано числа
Решить по pascal. дано числа a1, a9; b1, b11. максимальный элемент первой последовательности заменить на максимальный элемент второй последовательности и наоборот. программу оформить в виде "процедуры"
538VICTORIA8425
1 09.09.2019 22:30
1
Ответы
VikaRayder
09.09.2020 23:14
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!
procedure AB(a,b:array of integer);
begin
var (iaMax,ibMax):=(a.IndexMax,b.IndexMax);
var t:=a[iaMax]; a[iaMax]:=b[ibMax]; b[ibMax]:=t
end;
begin
var a:=ArrRandom(9,-99,99);
Write('A: '); a.Println;
var b:=ArrRandom(11,-99,99);
Write('B: '); b.Println;
AB(a,b);
Write('A: '); a.Println;
Write('B: '); b.Println;
end.
Пример
A: -46 -76 98 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 80 -50 -55
A: -46 -76 80 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 98 -50 -55
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Topergggg
30.11.2020 10:42
Анализируем и сравниваем С диаграммы Венна сравните окружностьи сферу. Назовите их сходства и различия. дам 15 б...
ЛераЛи123
30.11.2020 10:42
База данных содержит сведения о студентах: «Фамилия», «Год рождения», «Курс», «Оценка по информатике». Запрос для вывода списка студентов третьего курса 2000 г. рождения, имеющих...
stefa91
30.11.2020 10:43
Для выполнения каких действий используются инструмент вращения?...
plotnikovpetr
30.11.2020 10:43
1. Ниже приведена программа, записанная на языках программирования. Было проведено 9 запусков программы, при которых в качестве значений переменных s и t вводились следующие пары...
znaniya1402
30.11.2020 10:44
1. Что такое диаграмма? 2. Для чего используется диаграмма?3. Какие есть виды диаграмм?4. Как можно включить диаграмму в электронную таблицу?5. Как можно исправить или дополнить...
katerinatumasjp02dx5
30.11.2020 10:45
8. Выучи стихотворение М. Алимбаева и запиши его по памяти. Выполни морфологический разбор выделенных имён существи-тельных.Бабушка-мастерица,Ткёт ковёр-алаша“.Радугаз в небез...
Licona
30.11.2020 10:46
Составьте программу на языке Си для вычисления y при любом введенном значении x. y=1.3e^(1.3(x-4))+0.4x^(3)-2x^(2)-8.1...
MaksandSany
30.11.2020 10:47
Дайте характеристику основной памяти ПК...
veronikavolkova357
30.11.2020 10:54
ДАЮ 20Б. 1. На какие виды подразделяются инструменты программы SketchUp?2. Для чего предназначен инструмент Тяни толкай?3. Какова функция инструмента Окружность?...
KiskaSofia
30.11.2020 10:55
Устройства вывода ввода информации в ПК...
Популярные вопросы
Носорог спал, вытянув короткие лапы и положив на них тяжёлую голову. Его закрытые...
2
Угол 5 равен 120 градусов, угол 4 равен 45, найти угол 6...
3
1. Один — седой, другой молодой, Третий - скачет, а четвертый —- плачет. (Времена...
1
137 бет 5 тапсырма 9 сынып Қазақ тілі...
1
Put the verbs in brackets into the past simple passive.1, Robot is a sci-fi...
1
I get embarrassed when ... On Friday afternoons, I usually feel ... At the weekend,...
2
Как из формулы vср=2v1*v2/v1+v2 найти v1? ...
3
решить уравнения с полным решение б...
3
Каков будет ответ? ( не в дробях) Сколько будет в альтернативном виде, а не...
1
Система счёта, основанная на числе «шестьдесят», используется и в наши дни для...
2
// Внимание! Если программа не работает, обновите версию!
procedure AB(a,b:array of integer);
begin
var (iaMax,ibMax):=(a.IndexMax,b.IndexMax);
var t:=a[iaMax]; a[iaMax]:=b[ibMax]; b[ibMax]:=t
end;
begin
var a:=ArrRandom(9,-99,99);
Write('A: '); a.Println;
var b:=ArrRandom(11,-99,99);
Write('B: '); b.Println;
AB(a,b);
Write('A: '); a.Println;
Write('B: '); b.Println;
end.
Пример
A: -46 -76 98 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 80 -50 -55
A: -46 -76 80 -83 84 8 -14 46 8
B: 29 -36 37 78 -20 35 -77 -23 98 -50 -55